Login screen not registering a second identical character in a row

submitted by dysprosium edited

I am on Manjaro GNOME 45.4 (x11) and after some recent update, I am unable to type for example: aa, or 77, or ANY two identical characters in a row, so it only registers the first: a, 7, etc.

If I press the right arrow key, I am able to type another (identical) character, after which I'd have to repeat it again and again if I want all consecutive characters: e.g. aaaa.

Note: this only happens at the login screen, not lock screen or anywhere else.

Is this on purpose? Some security feature? This has to be the dumbest security feature I can image, especially since it doesn't tell you that it's skipping the character (which is not obvious if you type fast), and it also does let you HAVE a password of identical consecutive characters.

I only found this forum post about it:

Log in to comment



At work I'm on a really old version of Gnome and had the same issue. I noticed I could type consecutive characters if I added a pause of 1 to 2 seconds in between each press.

Of course this is not ideal. I finally found that some how the Accessibility option called Bouncing Keys (or Bouncy Keys?) was turned on which caused this behavior. Turning it off made things work as usual.

Not sure if this is your problem as well, but it's worth a look

mvirts , edited

I would chuck your accessibility options on the login screen, and maybe any input method that is between your keystrokes and the input target. I would have some more specifics for older gnome but these days I just use defaults all the time 😅. Do you havr more than one language installed in gnome settings? Or a language with special input modes?


Does the keyboard work as expected if you switch to a text console (eg. Ctrl+Alt+F2)?

Are you on the default stable branch?

If yes and yes, you can try reinstalling the libinput package, and make sure you don't have any libinput package installed from AUR.

Another thing you can try is to check your Gnome third party extensions if you have any, there were some issues I saw mentioned because some extensions haven't been updated to work with 45.

dysprosium [OP]

Does the keyboard work as expected if you switch to a text console (eg. Ctrl+Alt+F2)?

I'll try as soon as possible. But I do need to mention it only occurs at the login screen, not the lock screen. Perhaps this rules out package or extension issues, but I'll try reinstalling libinput either way, and fiddle with 3rd party extensions. Thanks for your reply


Not going to help a lot but may point to a motherboard issue - I've experienced this under Windows and a reboot has solved it.

dysprosium [OP]

it *only* happens *after* reboot. And after that there is no problem at all